Represents a morph element.
typedef struct { API_Elem_Head head; char filler_1[16]; bool isAutoOnStoryVisibility; bool filler_2[7]; API_StoryVisibility showContour; API_StoryVisibility showFill; API_LinkToSettings linkToSettings; API_ElemDisplayOptionsID displayOption; API_ElemViewDepthLimitationsID viewDepthLimitation; API_AttributeIndex buildingMaterial; API_PenOverrideType penOverride; API_AttributeIndex cutLineType; short cutLinePen; short uncutLinePen; API_AttributeIndex uncutLineType; API_AttributeIndex overheadLineType; short overheadLinePen; bool useCoverFillType; bool outlineContourDisplay; API_AttributeIndex coverFillType; short coverFillPen; short coverFillBGPen; bool use3DHatching; bool filler_3[3]; Int32 filler_4[8]; API_HatchOrientation coverFillOrientation; bool useDistortedCoverFill; bool filler_5[5]; API_OverriddenAttribute material; API_TextureProjectionTypeID textureProjectionType; Int32 filler_6[21]; API_Coord3D textureProjectionCoords[4]; double level; API_MorphBodyTypeID bodyType; API_MorphEdgeTypeID edgeType; bool castShadow; bool receiveShadow; bool filler_7[6]; Int32 filler_8[18]; API_Tranmat tranmat; bool filler_9[8]; } API_MorphType;
Members
- head
- General element header.
- edgeLinePen
- Pen index of the edges.
- isAutoOnStoryVisibility
- Is Auto On Story Visibility.
- showContour
- The option to define which stories display the contour of the morph.
- showFill
- The option to define which stories display the fill of the morph.
- linkToSettings
- Mode of linking to home story.
- displayOption
- Display options of the element on the floor plan (see API_ElemDisplayOptionsID).
- viewDepthLimitation
- Defines the range within the element is shown on the floor plan (see API_ElemViewDepthLimitationsID).
- buildingMaterial
- Building Material index of morph’s hatch.
- penOverride
- Cut fill pens set in the building material can be overridden on the element level.
- cutLineType
- Line Type of the cut contour.
- cutLinePen
- Pen of the cut contour.
- uncutLineType
- Line Type of the contour.
- uncutLinePen
- Pen of the contour.
- overheadLineType
- Line Type of view above (Floor plan only).
- overheadLinePen
- Pen of view above (Floor plan only).
- useCoverFillType
- Use Floor plan fill.
- outlineContourDisplay
- Outline Contour Display.
- coverFillType
- Floor plan fill type.
- coverFillPen
- Floor plan fill pen.
- coverFillBGPen
- Floor plan fill background pen.
- use3DHatching
- Floor plan fill from material.
- coverFillOrientation
- Floor plan local origo type of fill.
- useDistortedCoverFill
- Show hatching as projected onto a plane.
- material
- Material override structure of non customized surfaces.
- autoSegmentationType
- Automatic segmentation type of edges and surfaces.
- autoSegmentationNumber
- Segmentation number for automatic segmentation.
- textureProjectionType
- Projection type of texture.
- textureProjectionCoords
- Texture projection coordinate system.
- level
- Z position of the free shape.
- bodyType
- Type of the body (Solid, Surface).
- edgeType
- Type of the edge (Soft, Sharp).
- castShadow
- Body casts shadow.
- receiveShadow
- Body receives shadow.
- tranmat
- Tranmat of the morph element.
Remarks
In Archicad 17 the the elements’ cut fill foreground and background pens inherit from the building material, and can be overridden on the element level.
In Archicad 17 the the elements’ surface materials inherit from the building material, and can be overridden on the element level.
For morph related memo data see the ACAPI_Element_GetMemo function.
Requirements
- Version: API 16 or later
- Header: APIdefs_Elements.h
See Also
API_AttributeIndex, API_Elem_Head, API_Tranmat, API_Element, API_StoryVisibility
API_ElemDisplayOptionsID, API_ElemViewDepthLimitationsID
Element Manager, API Types