Specifies how the name of the drawing is assembled.
typedef enum { APIName_ViewOrSrcFileName, APIName_ViewIdAndName, APIName_CustomName } API_NameTypeValues;
Members
- APIName_ViewOrSrcFileName
- The drawing’s name is coming from the name of the view (for internal views) or file (for external drawings).
- APIName_ViewIdAndName
- The drawing’s name is coming from the ID and the name of the view.
- APIName_CustomName
- The drawing has a user-defined name.
Remarks
The options correspond to the different values in the Drawing Name popup on the Identification tabpage of the Drawing Settings dialog.
Requirements
- Version: API 10 or later
- Header: APIdefs_Elements.h