API_​NavigatorAddOnViewPointData

Describes a Navigator AddOn viewpoint root, group or leaf node.

    struct API_NavigatorAddOnViewPointData {
        GS::UniString                        displayId;
        GS::UniString                        displayName;
        API_NavigatorAddOnViewPointTypeID    itemType;
        API_Guid                             guid;
        API_Guid                             parentGuid;
        GSHandle                             data;
        UInt32                               viewSettingsFlags;

        API_NavigatorAddOnViewPointData ();
        API_NavigatorAddOnViewPointData (const API_NavigatorAddOnViewPointData& source);
        API_NavigatorAddOnViewPointData (API_NavigatorAddOnViewPointData&& source);
        ~API_NavigatorAddOnViewPointData ();

        void operator= (const API_NavigatorAddOnViewPointData& source);
        void operator= (API_NavigatorAddOnViewPointData&& source);
    };

 

Members

displayId
The display ID of the viewpoint.
displayName
The display name of the viewpoint.
itemType
The type of the viewpoint: root, group or leaf node. See API_NavigatorAddOnViewPointTypeID.
guid
Unique ID of the viewpoint.
parentGuid
Unique ID of the parent root/group of the viewpoint. The parent of a root is APINULLGuid.
data
The data stored by the AddOn in this viewpoint.
viewSettingsFlags
Specifies which view settings are enabled in this viewpoint leaf node. Not applicable for viewpoint roots or groups.
The value of this member can be set by combining the flags in API_NavigatorViewSettingsFlags.

 

Remarks

This is not POD type.

  • Do not use memset, BNZeroMemory or BNClear to initialize an object of this class. The constructors will initialize it.
  • Do not use BMKillHandle or BMHandleToHandle to manage the lifetime of the data member. The constructors, destructors and assignment operators of the class will manage it.

 

Requirements

Version: API 22 or later
Header: APIdefs_Navigator.h

 

See Also

API_NavigatorAddOnViewPointTypeID, API_NavigatorViewSettingsFlags, API_Guid