API_​NavigatorItem

Represents a Project Navigator item.

    typedef struct {
        GS::uchar_t                 uName[API_UniLongNameLen];
        GS::uchar_t                 uAutoTextedName[API_UniLongNameLen];
        char                        uiId[128];
        API_Guid                    guid;
        API_DatabaseInfo            db;
        short                       floorNum;
        short                       vType;
        API_CutPlanePlanConn        intendedPlanConn;
        API_Guid                    camId;
        API_NavigatorMapID          mapId;
        API_NavigatorItemTypeID     itemType;
        API_Guid                    sourceGuid;
        Int32                       owner;
        bool                        customName;
        bool                        customUiId;
        bool                        filler_2;
        bool                        isIndependent;
        Int32                       filler_3[6];
    } API_NavigatorItem;

 

Members

name
The name of the navigator item.
autoTextedName Featuring API 18
The name of the navigator item, in its original form (containing autotexts).
uiId Featuring API 10
The ID of the navigator item.
guid Changed in API 11
The own GUID of the navigator item
db
The database reference of the the navigator item.
floorNum
Floor index the navigator item refers to. Valid only if the type of the database is floorplan [itemType is API_StoryNavItem].
vType Featuring API 11
For internal use.
intendedPlanConn Featuring API 21
The status of the link between the navigator item and the Floor Plan
camId Changed in API 11
GUID of a single camera [itemType is API_CameraNavItem] or a camera set [itemType is API_CameraNavItem].
mapId Featuring API 10
The Project Navigator map wich contains this item.
itemType Featuring API 10
Type of the item.
sourceGuid Changed in API 24
The guid of the source navigator item. For example a View item can be the source of a Drawing or a PublisherSet item.
owner Featuring API 10
The member ID of the item’s owner in TeamWork mode (relevant only in View Map).
customName Featuring API 10
Custom name of the item (relevant only in the View Map and Layout Map).
customUiId Featuring API 10
Custom ID of the item (relevant only in the View Map and Layout Map).
isIndependent Featuring API 21
True when the navigator item is independent.

 

Remarks

This structure holds the data of an item of the Project Navigator.

The structure is used with the APINavigator_GetNavigatorItemID, APINavigator_GetNavigatorParentItemID, APINavigator_GetNavigatorChildrenItemsID, APINavigator_SearchNavigatorItemID and APINavigator_ChangeNavigatorItemID environment functions.

 

Requirements

Version: API 4.3 or later
Header: APIdefs_Navigator.h

 

See Also

API_DatabaseInfo, API_NavigatorMapID, API_NavigatorItemTypeID
API_NavigatorSet, API_NavigatorView
APINavigator_GetNavigatorItemID, APINavigator_SearchNavigatorItemID, APINavigator_ChangeNavigatorItemID
API Types