API_​NavigatorMapID

Enumeration of Project Navigator maps.

    typedef enum {
        API_UndefinedMap,
        API_ProjectMap,
        API_PublicViewMap,
        API_MyViewMap,
        API_LayoutMap,
        API_PublisherSets
    } API_NavigatorMapID;

 

Members

API_UndefinedMap
Undefined Project Navigator map.
API_ProjectMap
Project map.
API_PublicViewMap
Public View map.
API_MyViewMap
Your own view map (only in Teamwork mode).
API_LayoutMap
Layout map.
API_PublisherSets
Publisher Sets.

 

Remarks

This type identifier can be used as mapId in API_NavigatorSet and API_NavigatorItem structures.

 

Requirements

Version: API 10 or later
Header: APIdefs_Navigator.h

 

See Also

API_NavigatorItem
ACAPI_Notify_CatchViewEvent
API Types