Parameters of a project Navigator Set.
typedef struct { char name[128]; API_Guid guid; API_Guid rootGuid; API_NavigatorMapID mapId; bool wantsExtraInfo; char filler_0[3]; GS::UniString *host; GS::UniString *dirName; IO::Location *path; Int32 filler[3]; IO::Location *twFileServerPath;} API_NavigatorSet;
Members
- name
- The name of navigator set.
- guid
- The own GUID of the navigator set.
- rootGuid
- The GUID of the root.
- mapId
- The navigator set belongs to this map.
- wantsExtraInfo
- Indicates that you need the publishing information (
host
/dirname
/path
) for the set. - host
- Contains the host name for internet publishing.
- dirName
- Contains the directory name for internet publishing.
- path
- Contains the full output path for local/LAN publishing.
- twFileServerPath
- Output path on OpenBIMcloud (only when publishing to OpenBIMcloud, otherwise nullptr).
Remarks
This structure contains name, guid and root guid of a navigator set in Archicad. You can optionally obtain the publishing parameters as well, if the navigator set is a publisher set.
If the path
member is not nullptr
, it means the set will be published locally. If it is nullptr
, then the host
/dirName
pair contains the Internet publishing parameters. No extra information is available for other publishing types.
Call the ACAPI_Environment function with the APINavigator_GetNavigatorSetID function code to get this data.
Example:
Please see the PublishTest ()
and the UpdateTree ()
functions in the Navigator_Test example.
Requirements
- Version: API 4.3 or later (for
twFileServerPath
member: API 24 or later) - Header: APIdefs_Navigator.h
See Also
APINavigator_GetNavigatorSetID
APIDo_PublishID
API_NavigatorItem
API_NavigatorView
API_PublishPars
API Types