API_​NeigID

Describes the various special points of elements.

    typedef enum {
        APINeig_None                        = 0,
        APINeig_Wall                        = 1,
        APINeig_WallPl                      = 2,
        APINeig_WallOn                      = 3,
        APINeig_WallPlOn                    = 4,
        APINeig_Colu                        = 5,
        APINeig_Beam                        = 6,
        APINeig_BeamOn                      = 7,
        APINeig_BeamHole                    = 8,
        APINeig_Wind                        = 9,
        APINeig_WindHole                    = 10,
        APINeig_Door                        = 11,
        APINeig_DoorHole                    = 12,
        APINeig_Symb                        = 13,
        APINeig_Light                       = 14,
        APINeig_Ceil                        = 15,
        APINeig_CeilOn                      = 16,
        APINeig_Roof                        = 17,
        APINeig_RoofOn                      = 18,
        APINeig_RBL                         = 19,
        APINeig_RBLOn                       = 20,
        APINeig_Mesh                        = 21,
        APINeig_MeshOn                      = 22,
        APINeig_MeshRidge                   = 23,
        APINeig_MeshRidgeOn                 = 24,
        APINeig_DimInt                      = 25,
        APINeig_DimPt                       = 26,
        APINeig_DimOn                       = 27,
        APINeig_RadDim                      = 28,
        APINeig_LevDim                      = 29,
        APINeig_AngDim                      = 30,
        APINeig_AngDimOn                    = 31,
        APINeig_Word                        = 32,
        APINeig_Label                       = 33,
        APINeig_Room                        = 34,
        APINeig_RoomStamp                   = 35,
        APINeig_RoomOn                      = 36,
        APINeig_RoomRefPt                   = 37,
        APINeig_Hatch                       = 38,
        APINeig_HatchOn                     = 39,
        APINeig_Line                        = 40,
        APINeig_LineOn                      = 41,
        APINeig_PolyLine                    = 42,
        APINeig_PolyLineOn                  = 43,
        APINeig_Arc                         = 44,
        APINeig_ArcOn                       = 45,
        APINeig_Circ                        = 46,
        APINeig_CircOn                      = 47,
        APINeig_Spline                      = 48,
        APINeig_SplineOn                    = 49,
        APINeig_Hot                         = 50,
        APINeig_CutPlane                    = 51,
        APINeig_CutPlOn                     = 52,
        APINeig_Camera                      = 53,
        APINeig_CamSet                      = 54,
        APINeig_VirtSy                      = 55,
        APINeig_VirtSyOn                    = 56,
        APINeig_PictObj                     = 57,
        APINeig_Detail                      = 58,
        APINeig_DetailPoly                  = 59,
        APINeig_DetailPolyOn                = 60,
        APINeig_DetailMarker                = 61,
        APINeig_Symb3D                      = 62,
        APINeig_Light3D                     = 63,
        APINeig_Wind3D                      = 64,
        APINeig_Door3D                      = 65,
        APINeig_WindMark                    = 66,
        APINeig_DoorMark                    = 67,
        APINeig_CutPlMarker                 = 68,
        APINeig_WallPlClOff                 = 69,
        APINeig_WallPlOnClOff               = 70,
        APINeig_SymbOn                      = 71,
        APINeig_WindOn                      = 72,
        APINeig_DoorOn                      = 73,
        APINeig_LightOn                     = 74,
        APINeig_Note                        = 75,
        APINeig_SplineDir                   = 76,
        APINeig_DrawingCenter               = 77,
        APINeig_DrawingFrame                = 78,
        APINeig_DrawingFrameOn              = 79,
        APINeig_DrawingIDF                  = 80,
        APINeig_DrawingIDFOn                = 81,
        APINeig_DrawingTitle                = 82,
        APINeig_DrawingTitleOn              = 83,
        APINeig_Worksheet                   = 84,
        APINeig_WorksheetPoly               = 85,
        APINeig_WorksheetPolyOn             = 86,
        APINeig_WorksheetMarker             = 87,
        APINeig_Elevation                   = 88,
        APINeig_ElevationOn                 = 89,
        APINeig_ElevationMarker             = 90,
        APINeig_InteriorElevation           = 91,
        APINeig_InteriorElevationOn         = 92,
        APINeig_InteriorElevationMarker     = 93,
        APINeig_SectionSegment              = 94,
        APINeig_SectionSegmentOn            = 95,
        APINeig_SectionSegmentMarker        = 96,
        APINeig_CurtainWall                 = 97,
        APINeig_CurtainWallOn               = 98,
        APINeig_CurtainWallCut              = 99,
        APINeig_CurtainWallCutOn            = 100,
        APINeig_CWSegment                   = 101,
        APINeig_CWSegmentOn                 = 102,
        APINeig_CWSegmentBaseLine           = 103,
        APINeig_CWSegmentBaseLineOn         = 104,
        APINeig_CWFrame                     = 105,
        APINeig_CWFrameOn                   = 106,
        APINeig_CWFrame3D                   = 107,
        APINeig_CWPanel                     = 108,
        APINeig_CWPanel3D                   = 109,
        APINeig_CWJunction                  = 110,
        APINeig_CWJunction3D                = 111,
        APINeig_CWAccessory                 = 112,
        APINeig_CWAccessory3D               = 113,
        APINeig_Shell                       = 114,
        APINeig_ShellOn                     = 115,
        APINeig_Skylight                    = 116,
        APINeig_SkylightHole                = 117,
        APINeig_Skylight3D                  = 118,
        APINeig_SkylightOn3D                = 119,
        APINeig_SkylightOn                  = 120,
        APINeig_SkylightMark                = 121,
        APINeig_Morph                       = 122,
        APINeig_MorphOn                     = 123,
        APINeig_ChangeMarker                = 124,
        APINeig_ChangeMarkerPoly            = 125,
        APINeig_ChangeMarkerPolyOn          = 126,
        APINeig_ChangeMarkerMarker          = 127,
        APINeig_ColuOn                      = 128,
        APINeig_WordOn                      = 129,
        APINeig_CurtainWallBaseLine         = 130,
        APINeig_CurtainWallBaseLineOn       = 131,
        APINeig_StairOn                     = 132,
        APINeig_Tread                       = 133,
        APINeig_TreadOn                     = 134,
        APINeig_Riser                       = 135,
        APINeig_RiserOn                     = 136,
        APINeig_Stair                       = 137,
        APINeig_StairStructure              = 138,
        APINeig_StairStructureOn            = 139,
        APINeig_Railing                     = 140,
        APINeig_RailingOn                   = 141,
        APINeig_RailingToprail              = 142,
        APINeig_RailingToprailOn            = 143,
        APINeig_RailingHandrail             = 144,
        APINeig_RailingHandrailOn           = 145,
        APINeig_RailingRail                 = 146,
        APINeig_RailingRailOn               = 147,
        APINeig_RailingPost                 = 148,
        APINeig_RailingPostOn               = 149,
        APINeig_RailingInnerPost            = 150,
        APINeig_RailingInnerPostOn          = 151,
        APINeig_RailingBaluster             = 152,
        APINeig_RailingBalusterOn           = 153,
        APINeig_RailingPanel                = 154,
        APINeig_RailingPanelOn              = 155,
        APINeig_RailingToprailEnd           = 156,
        APINeig_RailingToprailEndOn         = 157,
        APINeig_RailingHandrailEnd          = 158,
        APINeig_RailingHandrailEndOn        = 159,
        APINeig_RailingRailEnd              = 160,
        APINeig_RailingRailEndOn            = 161,
        APINeig_RailingToprailConnection    = 162,
        APINeig_RailingToprailConnectionOn  = 163,
        APINeig_RailingHandrailConnection   = 164,
        APINeig_RailingHandrailConnectionOn = 165,
        APINeig_RailingRailConnection       = 166,
        APINeig_RailingRailConnectionOn     = 167,
        APINeig_RailingEndFinish            = 168,
        APINeig_RailingEndFinishOn          = 169,
        APINeig_BeamSegment                 = 170,
        APINeig_BeamSegmentOn               = 171,
        APINeig_ColumnSegment               = 172,
        APINeig_ColumnSegmentOn             = 173
    } API_NeigID;

 

Members

APINeig_None
No neig. Can be a return value e.g. in the APIIo_GetPointID functions.
APINeig_Wall
Wall end points (see picture below).
APINeig_WallPl
Wall corrected connection point (see picture below).
APINeig_WallOn
Wall reference line (see picture below).
APINeig_WallPlOn
Wall nonreference line (see picture below).
APINeig_Colu
Column origo and corners (see picture below).
APINeig_Beam
Beam points (see picture below).
APINeig_BeamOn
Beam segments (see picture below).
APINeig_BeamHole
Beam’s hole points (see picture below).
APINeig_Wind
Hotspots in the window object (see picture below).
APINeig_WindHole
Corners of window hole (see picture below).
APINeig_Door
Hotspots in the door object (see picture below).
APINeig_DoorHole
Corners of door hole (see picture below).
APINeig_Symb
Hotspots in the general object (see picture below). The inIndices are counted the way they were defined in the library part.
APINeig_Light
Hotspots in the light object (see picture below).
APINeig_Ceil
Vertices of the slab (see picture below). The inIndices are counted in the creation order starting from 1, i.e. the point the user first clicked will have inIndex 1. Later they can be taken from the vertexIDs.
APINeig_CeilOn
Edges of the slab (see picture below). The inIndices are counted in the creation order (the edge between corners 1 and 2 will have the inIndex 1, etc.); later they can be taken from the vertexIDs.
APINeig_Roof
Vertices of the roof polygon (see picture below). The inIndices are counted in the creation order starting from 1, i.e. the point the user first clicked will have inIndex 1. Later they can be taken from the vertexIDs.
APINeig_RoofOn
Edges of the roof polygon (see picture below). The inIndices are counted in the creation order (the edge between corners 1 and 2 will have the inIndex 1, etc.); later they can be taken from the vertexIDs.
APINeig_RBL Featuring API 15
Roof reference line points (see picture below).
APINeig_RBLOn
Roof reference line itself.
APINeig_Mesh
Vertices of the mesh (see picture below). The inIndices are counted in the creation order, starting from 1, i.e. the point the user first clicked will have inIndex 1. Later they can be taken from the vertexIDs.
APINeig_MeshOn
Edges of the mesh (see picture below). The inIndices are counted in the creation order (the edge between corners 1 and 2 will have the inIndex 1, etc.); later they can be taken from the vertexIDs.
APINeig_MeshRidge
Vertices of the mesh ridges (see picture below). The inIndices are counted in the creation order starting from 0 (!); the first ridge point the user clicked will have inIndex 0, etc. Later they can be taken from the vertexIDs.
APINeig_MeshRidgeOn
Edges of the mesh ridges (see picture below). The inIndices are counted in the creation order starting from 0 (!); the edge between ridge points 0 and 1 will have inIndex 1, etc. Later they can be taken from the vertexIDs.
APINeig_DimInt
Dimension segment (interval) as in old dimension.
APINeig_DimPt
Dimensioning point in the dimension chain (see picture below).
APINeig_DimOn
Dimension line (see picture below).
APINeig_RadDim
Radial dimension’s location (see picture below).
APINeig_LevDim
Level dimension marker’s center point (see picture below).
APINeig_AngDim
Angle dimension point (see picture below).
APINeig_AngDimOn
Angle dimension arc (see picture below).
APINeig_Word
Multiline text corners (see picture below).
APINeig_Label
Label points (see picture below).
APINeig_Room
Room corners (see picture below). The inIndices are counted in the creation order starting from 1, i.e. the point the user first clicked will have inIndex 1. Later they can be taken from the vertexIDs.
APINeig_RoomStamp
Room stamp hotspots (see picture below). The inIndices are counted in the order the hotspots are defined in the zone category library part.
APINeig_RoomOn
Room side lines (see picture below). The inIndices are counted in the creation order (the edge between corners 1 and 2 will have the inIndex 1, etc.); later they can be taken from the vertexIDs.
APINeig_RoomRefPt
Room reference point (see picture below).
APINeig_Hatch
Vertices of the hatch (see picture below). The inIndices are counted in the creation order starting from 1, i.e. the point the user first clicked will have inIndex 1. Later they can be taken from the vertexIDs.
APINeig_HatchOn
Edges of the hatch (see picture below). The inIndices are counted in the creation order (the edge between corners 1 and 2 will have the inIndex 1, etc.); later they can be taken from the vertexIDs.
APINeig_Line
Line end / middle points (see picture below).
APINeig_LineOn
The line itself (see picture below).
APINeig_PolyLine
The vertices of the polyline.
APINeig_PolyLineOn
The edges of the polyLine.
APINeig_Arc
Arc endpoints and center (see picture below).
APINeig_ArcOn
The arc itself (see picture below).
APINeig_Circ
Diagonals and center of circle (see picture below).
APINeig_CircOn
The circle itself (see picture below).
APINeig_Spline
Spline corners (see picture below).
APINeig_SplineOn
Spline segments (see picture below).
APINeig_Hot
The hotspot itself (see picture below).
APINeig_CutPlane
CutPlane points (see picture below).
APINeig_CutPlOn
CutPlane segments (see picture below).
APINeig_Camera
Camera points (see picture below).
APINeig_CamSet
Camera set points (see picture below).
APINeig_VirtSy
Virtual symbol hotspots (see picture below), in section/elevation windows.
APINeig_VirtSyOn
Virtual symbol lines (see picture below), in section/elevation windows.
APINeig_PictObj
Corners and center of pasted pictures (see picture below).
APINeig_Detail
Detail points.
APINeig_DetailPoly
Detail points.
APINeig_DetailPolyOn
Detail points.
APINeig_DetailMarker
Detail points.
APINeig_Symb3D
3D Hotspots in the general object.
APINeig_Light3D
3D Hotspots in the light object.
APINeig_Wind3D
3D Hotspots in the window object.
APINeig_Door3D
3D Hotspots in the door object.
APINeig_WindMark
Window marker points.
APINeig_DoorMark
Door marker points.
APINeig_CutPlMarker5.2
Section marker points.
APINeig_WallPlClOff5.2
Wall corner point when Clean Wall Intersections switch is off.
APINeig_WallPlOnClOff5.2
Wall non-reference line when Clean Wall Intersections switch is off.
APINeig_SymbOn6.1
Line status in the general object.
APINeig_WindOn6.1
Line status in the window object.
APINeig_DoorOn6.1
Line status in the door object.
APINeig_LightOn6.1
Line status in the light object.
APINeig_Note6.1
Note text hotspot.
APINeig_SplineDir Featuring API 10
Endpoint of spline direction handle (see picture below).
APINeig_DrawingCenter Featuring API 10
Center point of a drawing element (see picture below).
APINeig_DrawingFrame Featuring API 10
Corner point of the frame of a drawing element (see picture below).
APINeig_DrawingFrameOn Featuring API 10
Frame edge of a drawing element (see picture below).
APINeig_DrawingIDF Featuring API 10
Point status of the drawing content inside of a drawing element (see picture below).
APINeig_DrawingIDFOn Featuring API 10
Line status of the drawing content inside of a drawing element (see picture below).
APINeig_DrawingTitle Featuring API 10
Point status of a drawing title element (see picture below).
APINeig_DrawingTitleOn Featuring API 10
Line status of a drawing title element (see picture below).
APINeig_Worksheet
Worksheet points.
APINeig_WorksheetPoly
Worksheet polygon points.
APINeig_WorksheetPolyOn
Worksheet polygon line segments.
APINeig_WorksheetMarker
Worksheet marker points.
APINeig_Elevation
Elevation points.
APINeig_ElevationOn
Elevation line segments.
APINeig_ElevationMarker
Elevation marker points.
APINeig_InteriorElevation
Interior elevation points.
APINeig_InteriorElevationOn
Interior elevation line segments.
APINeig_InteriorElevationMarker
Interior elevation marker points.
APINeig_SectionSegment
Section segment points (for cut plane, elevation, and interior elevation).
APINeig_SectionSegmentOn
Section segment line segments (for cut plane, elevation, and interior elevation).
APINeig_SectionSegmentMarker
Section segment marker points (for cut plane, elevation, and interior elevation).
APINeig_CurtainWall Changed in API 12
Curtain wall end points.
APINeig_CurtainWallOn Changed in API 12
Curtain wall reference line.
APINeig_CurtainWallCut Changed in API 12
Curtain wall’s cutaway frames and panels points.
APINeig_CurtainWallCutOn Changed in API 12
Curtain wall’s cutaway frames and panels lines.
APINeig_CWSegment Changed in API 12
Curtain wall segment end points.
APINeig_CWSegmentOn Changed in API 12
Curtain wall segment reference line.
APINeig_CWSegmentBaseLine Changed in API 12
Curtain wall segment base reference line.
APINeig_CWSegmentBaseLineOn Changed in API 12
Curtain wall segment base reference line end points.
APINeig_CWFrame Changed in API 12
Vertexes of curtain wall frame.
APINeig_CWFrameOn Changed in API 12
Edges of curtain wall frame.
APINeig_CWFrame3D Changed in API 12
3D hotspots of curtain wall frame.
APINeig_CWPanel Changed in API 12
Vertexes of curtain wall panel.
APINeig_CWPanel3D Changed in API 12
3D hotspots in the curtain wall panel.
APINeig_CWJunction Changed in API 12
Vertexes of curtain wall junction.
APINeig_CWJunction3D Changed in API 12
3D hotspots of curtain wall junction.
APINeig_CWAccessory Changed in API 12
Vertexes of curtain wall accessory.
APINeig_CWAccessory3D Changed in API 12
3D hotspots in the curtain wall accessory.
APINeig_Shell Featuring API 15
Vertices of the shell polygon.
APINeig_ShellOn Featuring API 15
Edges of the shell polygon.
APINeig_Skylight Featuring API 15
Hotspots of the skylight object.
APINeig_SkylightHole Featuring API 15
Corners of skylight hole.
APINeig_Skylight3D Featuring API 15
3D hotspots of the skylight object.
APINeig_SkylightOn3D Featuring API 15
3D edges of the skylight object.
APINeig_SkylightOn Featuring API 15
Line status of the skylight object.
APINeig_SkylightMark Featuring API 15
Skylight marker points.
APINeig_Morph Featuring API 16
Vertices of the morph.
APINeig_MorphOn Featuring API 16
Edges of the morph.
APINeig_ChangeMarker
ChangeMarker points.
APINeig_ChangeMarkerPoly
ChangeMarker polygon points.
APINeig_ChangeMarkerPolyOn
ChangeMarker polygon line segments.
APINeig_ChangeMarkerMarker
ChangeMarker marker points.
APINeig_ColuOn 19
Area of the Column on Floor Plan (except Hotspots).
APINeig_WordOn 19
Area of Text (except Hotspots).
APINeig_CurtainWallBaseLine 19
Hotspots on a Curtain Wall’s Reference Line.
APINeig_CurtainWallBaseLineOn 19
Curtain Wall’s Reference Line (except Hotspots).
APINeig_StairOn 21
.
APINeig_Tread 21
.
APINeig_TreadOn 21
.
APINeig_Riser 21
.
APINeig_RiserOn 21
.
APINeig_Stair 21
.
APINeig_StairStructure 21
.
APINeig_StairStructureOn 21
.
APINeig_Railing 21
.
APINeig_RailingOn 21
.
APINeig_RailingToprail 21
.
APINeig_RailingToprailOn 21
.
APINeig_RailingHandrail 21
.
APINeig_RailingHandrailOn 21
.
APINeig_RailingRail 21
.
APINeig_RailingRailOn 21
.
APINeig_RailingPost 21
.
APINeig_RailingPostOn 21
.
APINeig_RailingInnerPost 21
.
APINeig_RailingInnerPostOn 21
.
APINeig_RailingBaluster 21
.
APINeig_RailingBalusterOn 21
.
APINeig_RailingPanel 21
.
APINeig_RailingPanelOn 21
.
APINeig_RailingToprailEnd 21
.
APINeig_RailingToprailEndOn 21
.
APINeig_RailingHandrailEnd 21
.
APINeig_RailingHandrailEndOn 21
.
APINeig_RailingRailEnd 21
.
APINeig_RailingRailEndOn 21
.
APINeig_RailingToprailConnection 21
.
APINeig_RailingToprailConnectionOn 21
.
APINeig_RailingHandrailConnection 21
.
APINeig_RailingHandrailConnectionOn 21
.
APINeig_RailingRailConnection 21
.
APINeig_RailingRailConnectionOn 21
.
APINeig_RailingEndFinish 21
.
APINeig_RailingEndFinishOn 21
.
APINeig_BeamSegment 23
.
APINeig_BeamSegmentOn 23
.
APINeig_ColumnSegment 23
.
APINeig_ColumnSegmentOn 23
.

 

Remarks

Here are the neigIDs with their inIndex in brackets for walls:

Wall neig 1
Wall neig 2

Here are the neigIDs with their inIndex in brackets for columns:

Column neig

Here are the neigIDs with their inIndex in brackets for windows (and very similar for doors):

Window neig

Here are the neigIDs with their inIndex in brackets for objects (and very similar for lamps):

Symbol neig

Here are the neigIDs with their inIndex in brackets for slabs:

Slab neig

Here are the neigIDs with their inIndex in brackets for roofs:

Roof neig

Here are the neigIDs with their inIndex in brackets for meshes:

Mesh neig

Here are the neigIDs with their inIndex in brackets for dimensions:

Dimension neig

Here are the neigIDs with their inIndex in brackets for radial dimensions:

Radial dimension neig

Here are the neigIDs with their inIndex in brackets for level dimensions:

Level dimension neig

Here are the neigIDs with their inIndex in brackets for angle dimensions:

Angle dimension neig

Here are the neigIDs with their inIndex in brackets for texts:

Text neig

Here are the neigIDs with their inIndex in brackets for labels:

Label neig

Here are the neigIDs with their inIndex in brackets for zones:

Zone neig

Here are the neigIDs with their inIndex in brackets for hatches:

Hatch neig

Here are the neigIDs with their inIndex in brackets for lines:

Line neig

Here are the neigIDs with their inIndex in brackets for arcs:

Arc neig

Here are the neigIDs with their inIndex in brackets for circles:

Circle neig

Here are the neigIDs with their inIndex in brackets for splines:

Spline neig

Here are the neigIDs with their inIndex in brackets for hotspots:

Hot neig

Here are the neigIDs with their inIndex in brackets for cutplanes:

Cutplane neig

Here are the neigIDs with their inIndex in brackets for cameras:

Perspective camera neig

Here are the neigIDs with their inIndex in brackets for virtual symbols:

Virtual symbol neig

Here are the neigIDs with their inIndex in brackets for pictures:

Picture neig

Here are the neigIDs with their inIndex in brackets for camera sets:

Camera set neig

Here are the neigIDs with their inIndex in brackets for beams:

Beam neig

Here are the neigIDs with their inIndex in brackets for drawings:

Drawing neig

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Elements.h

 

See Also

API_DimElem
API_DimBase
API Types