API_​NewProjectPars

Parameters to open a new project.

    typedef struct {
        bool     newAndReset;
        bool     enableSaveAlert;
        char     filler_1[6];
    } API_NewProjectPars;

 

Members

newAndReset
Performs New and Reset or just a simple New command
enableSaveAlert
Show the “Save the current document before closing” alert, or automatically save it before closing.

 

Remarks

For the utilization of this structure see the APIDo_NewProjectID automation function.

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Automate.h

 

See Also

APIDo_NewProjectID, API Types