API_​NewWindowPars

Parameters to open a new window.

    typedef struct {
        API_WindowTypeID     typeID;
        API_Guid             userRefId;
        GS::Int8             filler_1;
        bool                 useOriginalPenWeight;
        GS::uchar_t          wTitle[API_UniLongNameLen];
        GS::uchar_t          wFile[API_UniLongNameLen];
        Int32                filler_2[8];
    } API_NewWindowPars;

 

Members

typeID
type of the database; only APIWind_MyTextID and APIWind_MyDrawID are allowed.
userRefId Modified in API 22
free to use identifier of the window. Returned in notifications.
useOriginalPenWeight
The window uses original weight of pen attributes at line drawing instead of hairline.
wTitle[API_UniLongNameLen] Modified in API 11
the title of the window (Unicode, UTF-8 encoding)
wFile[API_UniLongNameLen] Modified in API 11
the default filename (Unicode, UTF-8 encoding)

 

Remarks

Refer to the APIDb_NewWindowID function for more details.

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Database.h

 

See Also

API_WindowTypeID
APIDb_NewWindowID
APIDb_NewDatabaseID
API Types