Structure describing a niche in a room.
typedef struct { API_Coord **coords; Int32 **pends; API_PolyArc **parcs; double height; } API_Niche;
Members
- coords
- Coordinate array.
- pends
- Polygon endpoints; see API_Polygon for more information.
- parcs
- Polygon arcs; see API_PolyArc and API_Polygon for more information.
- height
- Height of the niche
Remarks
The API_Niche
structure is a member of API_RoomRelation. If you need to add niches to area or volume calculation of a room, get the room relations with the ACAPI_Element_GetRelations function.
Requirements
- Version: API 2.1 or later
- Header: APIdefs_Elements.h