API_​NoteType

Describes a general note, used in dimensioning and hatch text.

    typedef struct {
        short                     notePen;
        short                     noteFont;
        API_AttributeIndex        noteLayer;
        double                    noteSize;
        double                    noteAngle;
        Int32                     filler_2[8];
        API_Coord                 pos;
        char                      content[64];
        GS::UniString             *contentUStr;
        API_NoteContentType       contentType;
        bool                      fixPos;
        bool                      filler_3;
        unsigned short            faceBits;
        bool                      opaque;
        bool                      frame;
        short                     backgroundPen;
        short                     framePen;
        short                     filler_4;
        Int32                     filler_5[4];
        bool                      useLeaderLine;
        bool                      anchorAtTextEnd;
        short                     filler_6[3];
        API_Coord                 begC;
        API_Coord                 midC;
        API_Coord                 endC;
        Int32                     filler_7;
        short                     filler_8;
        short                     leaderPen;
        API_AttributeIndex        leaderLineType;
        API_LeaderLineShapeID     leaderShape;
        API_ArrowData             arrowData;
        API_LblAnchorID           anchorPoint;
        API_JustID                just;
        double                    widthFactor;
        double                    spacingFactor;
        short                     rowAnchor;
        unsigned short            effectBits;
    } API_NoteType;

 

Members

notePen
Pen attribute index.
noteLayer
Layer attribute index.
noteFont
Font attribute index.
noteSize
The character height in mm.
noteAngle
Rotation angle in radian.
pos
Coordinates of left bottom.
content[64] Modified in 14
The text or the autotext of the note.
contentUStr Modified in 17
Optional parameter for accessing the text or the autotext of the note in UniString format.
contentType Modified in 14
0: measured value 1: custom text
fixPos
Is the position of the note manually fixed?
faceBits
The style of the note:

APIFace_Plain

Plain text

APIFace_Bold

Bold

APIFace_Italic

Italic

APIFace_Underline

Underline

subContent[8]
Extra text (required in certain markets), e.g.: Small 5, Small 25, Small 75.
opaque 13
The note has background.
frame 13
The note has frame.
backgroundPen 13
The background color index if opaque.
framePen 13
Frame color index if framed.
useLeaderLine 19
Whether the note has leader line.
anchorAtTextEnd 19
Whether the leader line attached to the end of the note text.
begC 19
Beginning coordinate of the leader line.
midC 19
Middle coordinate of the leader line.
endC 19
End coordinate of the leader line.
leaderPen 19
Leader line pen attribute index.
leaderLineType 19
Line type attribute index of the leader line.
leaderShape 19
Shape of the leader line.
arrowData 19
The arrow type. See API_ArrowData
anchorPoint 19
Anchor point the pointer line is connected to. See API_LblAnchorID.
just 21
Multiline Text alignment (Left, Center, Right).
widthFactor 21
Width scale of the note’s text.
spacingFactor 21
Spacing scale of the note’s text.
rowAnchor 19
Text anchor row (First = 0, or Last Row = 1).
effectBits 21
Special text effects:
APIEffect_StrikeOut Strikethrough text
APIEffect_SuperScript Superscript
APIEffect_SubScript Subscript
APIEffect_Protected Protected text (autotext reference)

 

Remarks

This type is used in many as text blocks of any kind of dimensions.

You can only create notes with leader line on angle dimensions, floor plan dimensions and hatches. If you want to create a note with leaderline you will have to set fixpos to true, but you do not have to calculate pos and noteAngle because leaderline will determine these automatically.

subContent is removed in API 14.

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Elements.h

 

See Also

API_Coord
API_HatchType
API_WindowType
API_DoorType
API_DimensionType
API_RadialDimensionType
API_LevelDimensionType
API_AngleDimensionType
API_DimElem
API_AttributeIndex
API Types