Describes the element the notification is coming for, and the type of the notification.
typedef struct { API_ElementDBEventID notifID; Int32 filler_1; API_Elem_Head elemHead; API_DatabaseUnId databaseId; Int32 filler_2[8]; } API_NotifyElementType;
Members
- notifID
- The type of the notification.
- filler_1
- Reserved for later use.
- elemHead
- Element reference.
- databaseId
- Element database identifier.
- filler_2
- Reserved for later use.
Remarks
This is the parameter of the APIElementEventHandlerProc callback function, identifying the element and the type of notification your add-on was called for.
In order to receive the notifications of created elements you should install an APIElementEventHandlerProc with the ACAPI_Notify_CatchNewElement function.
To be notified on deleting or modifying a specified element, attach an observer to the element you are interested in with ACAPI_Element_AttachObserver with the appropriate flags.
You should definitely not modify the project database during APINotifyElement_Undo and APINotifyElement_Redo notifications.
The Notification Manager section explains how the element related notifications are sent to the add-ons. Since each add-on can be notified twice during the same operation, the first call is marked with a
-1
index value in the APINotifyElement_BeginEvents notification. This helps you to distinguish the first and the second APINotifyElement_BeginEvents (for example if you have to keep the data synchronized with an external database).
Requirements
- Version: API 4.1 or later
- Header: APIdefs_Callback.h
See Also
APIElementEventHandlerProc
API_ElementDBEventID
API_ElemTypeID
ACAPI_Notify_CatchNewElement
ACAPI_Element_AttachObserver
ACAPI_Notify_GetParentElement
Notification Manager
API Types