Possible values for notifications on project events.
typedef enum { APINotify_New, APINotify_NewAndReset, APINotify_Open, APINotify_PreSave, APINotify_Save, APINotify_Close, APINotify_Quit, APINotify_TempSave, APINotify_ConvertUnId, APINotify_ConvertGuid, APINotify_ConvertLinkId, APINotify_ConvertDrwGuid, APINotify_SendChanges, APINotify_ReceiveChanges, APINotify_ChangeProjectDB, APINotify_ChangeWindow, APINotify_ChangeFloor, APINotify_ChangeLibrary, APINotify_AllInputFinished, APINotify_UnitChanged, APINotify_SideviewCreated, APINotify_SideviewRebuilt, APINotify_PropertyVisibilityChanged, APINotify_ClassificationVisibilityChanged, APINotify_ShowIn3DChanged } API_NotifyEventID;
Members
- APINotify_New
- The user chose New from the File menu.
- APINotify_NewAndReset
- The user chose New & Reset from the File menu.
- APINotify_Open
- The user opened an existing project.
- APINotify_PreSave
- The user has chosen Save from the File menu; this notification is coming before the actual save is performed, so that you could save some data into the project file. Please try to avoid using this method if not necessary, because it can significantly slow down the file saving process. Rather store the additional data into the project when they actually change.
- APINotify_Save
- The user has chosen Save from the File menu; the project has already been saved.
- APINotify_Close
- The user closed the current project.
- APINotify_Quit
- The user chose Quit from the File menu.
- APINotify_TempSave
- The project is about to be autosaved.
- APINotify_ConvertUnId
- An old (Archicad 10 or older) project file was opened, and conversion of unIds stored in user datas or module datas may be necessary. Use the ACAPI_Element_UnIdToGuid function to perform the conversion. This notification is issued after the project file has been loaded but before APINotify_Open notification.
- APINotify_ConvertGuid
(obsolete function, not used any more)
- Archicad started saving a version 10.0 file, and conversion of API_Guids stored in user datas or modul datas may be necessary. Use the ACAPI_Element_GuidToUnId function to perform the conversion. This notification is issued after the APINotify_PreSave notification but before anything is actually written.
- APINotify_ConvertLinkId
- The
linkUId
member of API_DrawingType strucure is not used anymore. APIDb_GetDrawingLinkID function requires the drawing’s guid instead oflinkUId
.
An old (Archicad 11 or older) project file was opened, and conversion oflinkUId
s stored in user datas or module datas may be necessary. Use the ACAPI_Element_LinkIdToDrwGuid function to perform the conversion. This notification is issued after the project file has been loaded but before APINotify_Open notification. - APINotify_ConvertDrwGuid
- The
linkUId
member of API_DrawingType strucure is not used anymore. APIDb_GetDrawingLinkID function requires the drawing’s guid instead oflinkUId
.
Archicad started saving a version 10.0 file, and conversion of drawings’API_Guids stored in user datas or modul datas may be necessary. Use the ACAPI_Element_DrwGuidToLinkId function to perform the conversion. This notification is issued after the APINotify_PreSave notification but before anything is actually written. - APINotify_SendChanges
- The user is about to send changes into the Teamwork project.
- APINotify_ReceiveChanges
- The user has received the changes from the Teamwork project.
- APINotify_ChangeProjectDB
- The project database changed.
- APINotify_ChangeWindow
- The current window changed.
- APINotify_ChangeFloor
- The user switched to an other floor.
- APINotify_ChangeLibrary
- The loaded libraries were changed.
- APINotify_AllInputFinished
- Sent when an input process (open, merge, etc.) is finished.
- APINotify_SideviewCreated
- The section/elevation/interior elevation was generated. The first time was opened its window.
- APINotify_SideviewRebuilt
- The section/elevation/interior elevation was rebuilt.
- APINotify_UnitChanged
- Notifies that the working units or calculation units have changed on Preferences dialogs.
- APINotify_PropertyVisibilityChanged
- Notifies that Property visibility has changed.
- APINotify_ClassificationVisibilityChanged
- Notifies that Classification visibility has changed.
- APINotify_ShowIn3DChanged
- This notification is sent when the user has chosen Show Selection in 3D / Show All in 3D / Show stored selection in 3D.
Remarks
Refer to ACAPI_Notify_CatchProjectEvent function for further details.
The following irrelevant notifications have been removed in API 14: APINotify_Share
, APINotify_SignIn
, APINotify_SignOut
, and APINotify_ChangeWorkspace
.
Requirements
- Version: API 4.1 or later
- Header: APIdefs_Callback.h