Describes the Project Navigator item the notification is coming for, and the type of the notification.
typedef struct { API_NotifyViewEventID notifID; API_NavigatorMapID mapId; API_Guid itemGuid; } API_NotifyViewEventType;
Members
- notifID
- The type of the notification.
- mapId
- This Project Navigator map contains the item the nofication is coming for.
- itemGuid
- The own GUID of the navigator item.
Remarks
This is the parameter of the APIViewEventHandlerProc callback function, identifying the navigator item and the type of notification your add-on was called for.
In order to receive the notifications of inserted, deleted, changed or opened items you should install an APIViewEventHandlerProc with the ACAPI_Notify_CatchViewEvent function.
Requirements
- Version: API 10 or later
- Header: APIdefs_Callback.h
See Also
API_NotifyViewEventID, API_NavigatorMapID
APIViewEventHandlerProc, ACAPI_Notify_CatchViewEvent
API Types