API_​NumberingGridLine

Represents a drawing numbering grid line of the layout.

    typedef struct {
        API_Coord            begC;
        API_Coord            endC;
        short                penInd;
        API_AttributeIndex   ltypeInd;
        Int32                filler_1[7];
    } API_NumberingGridLine;

 

Members

begC
Coordinate of the starting point
endC
Coordinate of the endpoint
penInd
Pen attribute index
ltypeInd
Line type attribute index

 

Remarks

This structure holds the data of a line of the grid-based drawing numbering system.
The stucture is passed as a parameter of the APINumberingGridLineProc callback function while the drawing numbering grid lines are being enumerated by the APIEnv_GetNumberingGridLinesID environment function.

 

Requirements

Version: API 6.1 or later
Header: APIdefs_Environment.h

 

See Also

APIEnv_GetNumberingGridLinesID
API_AttributeIndex
APINumberingGridLineProc
API_Coord
API Types