API_​NumberingStyle

Describes the Layout ID styles.

    typedef enum {
        API_NS_Undefined,
        API_NS_abc,
        API_NS_ABC,
        API_NS_1,
        API_NS_01,
        API_NS_001,
        API_NS_0001,
        API_NS_noID
    } API_NumberingStyle;

 

Members

API_NS_Undefined
Undefined style.
API_NS_abc
a, b, c,…
API_NS_ABC
A, B, C,…
API_NS_1
1, 2, 3,…
API_NS_01
01, 02, 03,…
API_NS_001
001, 002, 003,…
API_NS_0001
0001, 0002, 0003,…
API_NS_noID
No ID.

 

Remarks

API_SubSet contains this structure. APIDb_CreateSubSetID function creates a Subset in the Layout Book.

 

Requirements

Version: API 12 or later
Header: APIdefs_Database.h

 

See Also

API_HotlinkNode
API Types