API_​ObjectSettingsPars

Defines the parameters of the Object Settings dialog.

    typedef struct {
        API_Element        elemDef;
        API_Element        elemMask;
        API_AddParType     **addPars;
        char               subtypeID [128];
        Int32              propIndivLibInd;
        bool               propCriteria;
        char               filler_1[3];
        Int32              filler_2[31];
    } API_ObjectSettingsPars;

 

Members

elemDef
[in/out] the default symbol on input; the selected symbol on output
elemMask
[in] defines which fields of elemDef should be used only
addPars
[out] additional symbol parameters
subtypeID
[in] GUID string of the object subtype
propIndivLibInd 6.1
[out] library index of individually assigned property object to be linked to the element (value zero means no property assigned individually)
propCriteria 6.1
[out] matching properties by criteria need to be linked to the element

 

Remarks

See the remarks and the example for APIIo_ObjectSettingsID.

 

Requirements

Version: API 4.1 or later
Header: APIdefs_Interface.h

 

See Also

APIIo_ObjectSettingsID
API_Element
API_AddParType
API Types