API_​ObjectType

Represents an object or a lamp, or a symbol label.

    typedef struct {
        API_Elem_Head           head;
        short                   pen;
        short                   filler_0;
        API_AttributeIndex      ltypeInd;
        API_AttributeIndex      mat;
        API_AttributeIndex      sectFill;
        short                   sectFillPen;
        short                   sectBGPen;
        short                   sectContPen;
        short                   filler_1;
        bool                    useObjPens;
        bool                    useObjLtypes;
        bool                    useObjMaterials;
        bool                    reflected;
        bool                    useXYFixSize;
        bool                    useObjSectAttrs;
        short                   fixPoint;
        double                  angle;
        double                  level;
        double                  xRatio;
        double                  yRatio;
        API_Coord               offset;
        Int32                   fixedAngle;
        char                    filler_2[12];
        API_RGBColor            lightColor;
        API_StoryVisibility     visibility;
        API_LinkToSettings      linkToSettings;
        bool                    lightIsOn;
        bool                    isAutoOnStoryVisibility;
        bool                    filler_3[6];
        Int32                   filler_4;
        API_ElemType            ownerType;
        API_Guid                owner;
        Int32                   libInd;
        Int32                   filler_5;
        API_Coord               pos;
        bool                    filler_6[4];
        GS::Int64               lookId;
        Int32                   filler_7[3];
    } API_ObjectType, API_LampType;

 

Members

head
General element header.
pen
Pen attribute index.
ltypeInd
Line type attribute index.
mat
Material attribute index.
sectFill
Section fill attribute index.
sectFillPen
Section fill pen attribute index.
sectBGPen
Section fill background pen attribute index.
sectContPen
Section fill contour pen attribute index.
useObjPens
Use the pens defined in the library part?
useObjLtypes
Use the line types defined in the library part?
useObjMaterials
Use the materials defined in the library part?
reflected
Is the symbol reflected?
useXYFixSize
Use the A and B values as fixed sizes?
useObjSectAttrs
Use the section attributes defined in the library part?
fixPoint
The index-1 of hotspot to keep fixed.
angle
The rotation angle (radian).
level
The base height from the floor level.
xRatio
The ratio of the size of the placed object/lamp in the X direction and the A value defined in the library part (multiplication factor in X direction).
yRatio
The ratio of the size of the placed object/lamp in the Y direction and the B value defined in the library part (multiplication factor in Y direction).
offset
Offset of the symbol’s origin from insertion point.
fixedAngle New in API 22
Use fix angle.
lightColor
Color of the light (for lamps only).
visibility
Visibility information of the object/lamp. 6.1
linkToSettings Featuring API 11
Mode of linking to home story.
lightIsOn
The light is on/off.
isAutoOnStoryVisibility Featuring API 19
Recalculate the story visibility automatically according to the actual vertical extent of the object (“All Relevant Stories”).
ownerType
Type of the owner (external object).
owner Changed in API 12
Index of the owner element of the object.
libInd
Index to the symbol in the library.
pos
Position of the origin of the object.
lookId Changed in API 16
Same number for similar-looking objects/lamps 2D draw.

 

Remarks

For beam related memo data see the ACAPI_Element_GetMemo function.

New in API 26 From version 26 the type of the ownerID member was changed into API_ElemType.

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Elements.h

 

See Also

API_Elem_Head, API_AttributeIndex, API_Coord, API_RGBColor, API_Element,
API_Gable, API_AddParType, API_ElementMemo
API_StoryVisibility, API_LinkToSettings
Element Manager, API Types