Description of a component.
typedef struct { API_ListData_Head head; char code[API_DBCodeLen]; char keycode[API_DBCodeLen]; char name[API_DBNameLen]; char unitcode[API_DBCodeLen]; char dbSetName[API_DBCodeLen]; double quantity; short unitRef; short filler_1; Int32 filler_2[7]; } API_Obsolete_ComponentType;
Members
- head
- Contains the header information, including type, setIndex and index.
- code
- code string
- keycode
- key code string
- name
- name of the component
- unitcode
- code for unit
- dbSetName
- the name of the database set; important when the component is not found in the active databases, because you can still find out which database it came from
- quantity
- quantity (value) of the component
- unitRef
- unit type, see the APIUnitRef_xxx defines.
Remarks
This structure is obsolete. Use the new component API instead.
This stucture is used when you get or search a component in the listing database. See the ACAPI_ListData_Get, ACAPI_ListData_GetLocal and ACAPI_ListData_Search functions.
Requirements
- Version: API 4.1 or later
- Header: APIdefs_ListData.h