API_​OnScreenViewOptions

Representation of the display only options.

    typedef struct {
        char     wallMode;
        bool     showRoofPivLine;
        bool     showFillHandles;
        char     lineWeight;
        char     textMode;
        char     figureMode;
        bool     showExtrudedBodies;
        char     camPathViewMode;
        char     wallMethod;
        bool     showMarkerRange;
        char     filldrawingMode;
        bool     splineMode;
        bool     showDrawingFrames;
        bool     showMasterItems;
        bool     boldCutLines;
        bool     showSourceMarkerBound;
        bool     showDimensionAllLines;
        char     filler_1[7];
    } API_OnScreenViewOptions;

 

Members

wallMode
The wall and beam intersection display method.
Possible values: API_Drawing_Clean, API_Drawing_Constr.
showRoofPivLine
Specifies whether roof pivot lines are displayed.
showFillHandles
Specifies whether Fill handles are displayed.
lineWeight
Specifies whether lines are displayed with their true weight.
Possible values: API_LWeight_On, API_LWeight_Hairline.
textMode
Specifies whether Text block handles are displayed.
Possible values: API_TextSet_Normal, API_TextSet_Handles.
figureMode
Specifies whether Figure handles are displayed.
Possible values: API_Figure_WithHandles, API_Figure_WithoutHandles.
showExtrudedBodies 11
Specifies to show cut bodies for shell and roof in 3D (OpenGL only).
camPathViewMode
Specifies camera path visibility (Archicad only).
Possible values: API_CamPath_None, API_CamPath_CamerasOnly, API_CamPath_CamerasAndPath, API_CamPath_Everything.
wallMethod
Specifies the beam drawing style (Archicad only).
Possible values: API_Wall_Drawing_Contour, API_Wall_Drawing_RefLine.
showMarkerRange 11
Specifies if the range of different markers is visible.
filldrawingMode 10
Specifies the how vector fills are displayed.
Possible values are: API_Fill_Vector, API_Fill_Bitmap.
splineMode 10
Specifies whether spline handles are visible.
showDrawingFrames 10
Specifies whether drawing frames are visible.
showMasterItems 10
Specifies whether master layout items are visible on layouts.
boldCutLines
Specifies whether cut lines are displayed as bold.
showSourceMarkerBound 11
Specifies if the bounds of markers are visible.
showDimensionAllLines 20
Specifies if dimensions’ reference lines should be visible.

 

Remarks

These settings correspond to the relevant items in the View/On-Screen View Options menu.

Call the ACAPI_Environment function with the APIEnv_GetViewOptionsID or APIEnv_ChangeViewOptionsID function codes to operate on this data.

 

Requirements

Version: API 10 or later
Header: APIdefs_Environment.h

 

See Also

APIEnv_GetViewOptionsID, APIEnv_ChangeViewOptionsID,
API Types