Represents the common part of window, door and skylight elements.
typedef struct { short pen; short filler_0; API_AttributeIndex ltypeInd; API_AttributeIndex mat; API_AttributeIndex sectFill; short sectFillPen; short sectBGPen; short sectContPen; short filler_1; API_AttributeIndex cutLineType; API_AttributeIndex aboveViewLineType; short aboveViewLinePen; short belowViewLinePen; API_AttributeIndex belowViewLineType; bool useObjPens; bool useObjLtypes; bool useObjMaterials; bool useObjSectAttrs; bool filler_2[4]; double width; double height; double subFloorThickness; char filler_3[16]; Int32 libInd; API_VerticalLink verticalLink; bool reflected; bool oSide; bool refSide; bool wallCutUsing; bool filler_4[4]; GS::Int64 lookId; API_Guid markGuid; API_ElemDisplayOptionsID displayOption; Int32 filler_5; } API_OpeningBaseType;
Members
- pen
- Pen index.
- ltypeInd
- Line type index.
- mat
- Material index.
- sectFill
- Fill index of section of the opening.
- sectFillPen
- Pen index of the fill of the section of the opening.
- sectBGPen
- Background pen index of the fill of the section of the opening.
- sectContPen
- Contour pen index of the fill of the section of the opening.
- cutLineType
- Line type index for cut lines of the opening.
- aboveViewLinePen
- Pen used when “Overhead All” is selected from the “Floor Plan Display” popup. Corresponds to the “Overhead Line Pens” value in the Door/Window Settings dialog.
- aboveViewLineType
- Line type used when “Overhead All” is selected from the “Floor Plan Display” popup. Corresponds to the “Overhead Lines” value in the Door/Window Settings dialog.
- belowViewLinePen
- Pen index of the uncut lines of the opening.
- belowViewLineType
- Line type used when “OutLines Only” is selected from the “Floor Plan Display” popup. Corresponds to the “Uncut Lines” value in the Door/Window Settings dialog.
- useObjPens
- Use the pens defined in the library part.
- useObjLtypes
- Use the line types defined in the library part.
- useObjMaterials
- Use the materials defined in the library part.
- useObjSectAttrs
- Use the section attributes defined in the library part.
- width
- Width of the opening.
- height
- Vertical size of the opening.
- subFloorThickness
- Sub-floor thickness (used to be Parapet correction
ppCorr
). - libInd
- Index to the symbol in the library. If 0, an empty window/door/skylight hole is created.
- verticalLink
- The anchor position defining how the window/door element to be kept fixed during elevation changes.
- reflected
- True if mirrored to Y axis.
- oSide
- True if mirrored to X axis.
- refSide
- True if mirrored to X axis (same as
oSide
). - wallCutUsing
- True if the window inherits the gables of the owner wall.
- lookId
- Same number for similar-looking windows/doors/skylights 2D draw.
- markGuid
- Guid of the dimension marker symbol.
- displayOption
- Display options of the element on the floor plan (see API_ElemDisplayOptionsID).
Remarks
This structure is created from
API_WindowType
to hold the common parameters of API_WindowType and API_SkylightType.
For window/door/skylight related memo data see the ACAPI_Element_GetMemo function.
Requirements
- Version: API 15 or later
- Header: APIdefs_Elements.h
See Also
API_Elem_Head, API_AttributeIndex, API_VerticalLink, API_ElemDisplayOptionsID
API_WindowType, API_SkylightType, API_Element, API_ElementMemo
Element Manager, API Types