API_​OpeningConstraintTypeID

Opening constraint.

    typedef enum {
        API_OpeningForcedVertical,
        API_OpeningForcedHorizontal,
        API_OpeningAligned,
        API_OpeningFree
    } API_OpeningConstraintTypeID;

 

Members

API_OpeningForcedVertical 21
Opening is vertical.
API_OpeningForcedHorizontal 21
Opening is horizontal.
API_OpeningAligned 23
Opening is aligned to the associated element.
API_OpeningFree 23
Custom opening.

 

Requirements

Version: API 23 or later
Header: APIdefs_Elements.h

 

See Also

API Types