API_​OpeningCoverFillsParameters

Opening cover fills parameters.

    typedef struct {
        bool                           useCoverFills;
        bool                           useFillsOfCutElements;
        short                          filler_1;
        API_AttributeIndex             coverFillIndex;
        short                          coverFillPenIndex;
        short                          coverFillBackgroundPenIndex;
        API_HatchOrientationTypeID     coverFillOrientation;
    } API_OpeningCoverFillsParameters;

 

Members

useCoverFills
Use cover fills.
useFillsOfCutElements
Use fills of cut elements.
coverFillIndex
Cover fill index.
coverFillPenIndex
Cover fill pen index.
coverFillBackgroundPenIndex
Cover fill background pen index.
coverFillOrientation
Cover fill orientation (API_HatchGlobal, API_HatchRotated, API_HatchDistorted).

 

Requirements

Version: API 23 or later
Header: APIdefs_Elements.h

 

See Also

API Types, API_OpeningFloorPlanParameters