Opening extrusion parameters.
typedef struct { API_OpeningBasePolygonTypeTypeID basePolygonType; short filler_1[2]; double width; double height; API_OpeningConstraintTypeID constraint; API_AnchorID anchor; double anchorAltitude; API_OpeningLimitTypeTypeID limitType; short filler_2[2]; double extrusionStartOffset; double finiteBodyLength; API_OpeningLinkedStatusTypeID linkedStatus; short filler_3[2]; } API_OpeningExtrusionParameters;
Members
- basePolygonType
- Type of base polygon.
- width
- Width of base polygon. Valid only if base polygon is rectangular or circular.
- height
- Height of base polygon. Valid only if base polygon is rectangular or circular.
- constraint
- Extrusion limit type.
- anchor
- The anchor point of the opening.
- anchorAltitude
- Altitude of opening anchor. Valid only if constraint is forced horizontal or aligned.
- limitType
- Extrusion limit type.
- extrusionStartOffset
- Offset from reference plane of the opening. Valid only if limitType is not infinite.
- finiteBodyLength
- Extrusion body length. Valid only if limitType is finite.
- linkedStatus
- Linked dimensions type. Valid only if base polygon is rectangular or circular.
Requirements
- Version: API 23 or later
- Header: APIdefs_Elements.h