API_​OpeningOutlinesParameters

Opening outlines parameters.

    typedef struct {
        API_OpeningFloorPlanOutlinesStyleTypeID     outlinesStyle;
        bool                                        useLineOfCutElements;
        bool                                        filler_1;
        short                                       filler_2;
        API_AttributeIndex                          uncutLineIndex;
        API_AttributeIndex                          overheadLineIndex;
        short                                       uncutLinePenIndex;
        short                                       overheadLinePenIndex;
        short                                       filler_3[2];
    } API_OpeningOutlinesParameters;

 

Members

outlinesStyle 21
Type of contours on open edges.
useLineOfCutElements
Use contours of cut elements.
uncutLineIndex
Uncut line.
overheadLineIndex
Overhead line.
uncutLinePenIndex
Uncut line pen.
overheadLinePenIndex
Overhead line pen.

 

Requirements

Version: API 23 or later
Header: APIdefs_Elements.h

 

See Also

API Types, API_OpeningFloorPlanParameters