API_​OpeningType

Represents an opening element

    typedef struct {
    API_Elem_Head                        head;
    API_Guid                             owner;
    API_OpeningFloorPlanParameters       floorPlanParameters;
    API_OpeningExtrusionGeometryData     extrusionGeometryData;
    double                               filler_1;
    } API_OpeningType;

 

Members

head
General element header.
owner
Reference to the element the opening is associated to. (see API_Guid).
floorPlanParameters 21
Floor plan parameters of the opening.
extrusionGeometryData 21
Geometry data of the opening extrusion.

 

Remarks

Opening symbols can not be accessed in this version.

 

Requirements

Version: API 23 or later
Header: APIdefs_Elements.h

 

See Also

API Types, ACAPI_Element_GetConnectedElements