API_​OperationProfileType

An Energy Evaluation operation profile.

    typedef struct {
        API_Attr_Head           head;
        short                   nDailyProf;
        short                   nDailyProfUsage;
        API_OccupancyTypeID     occupancyType;
        double                  hotWaterLoad;
        double                  humanHeatGain;
        double                  humidity;
    } API_OperationProfileType;

 

Members

head
Contains the name and the index of the attribute.
nDailyProf
Specifies the total number of Daily Profiles.
nDailyProfUsage
Specifies the total number of Daily Profile Usages.
API_OccupancyTypeID
Specifies the occupancy type of the Operation Profile.
hotWaterLoad
Service hot water load.
humanHeatGain
Human heat gain.
humidity
Humidity load.

 

Remarks

There are additional data assigned to operation profile attributes in the API_AttributeDefExt structure; the definition of an operation profile are passed through the op_dailyProfiles and op_dailyProfileUsages fields. Refer to the API_DailyProfile and API_DailyProfileUsage structures to get more details on it.

The coverage of an entire year (8760 hours) can be queried by the op_hourlyProfiles structure. Refer to the API_HourlyProfile structure to get more details on it.

 

Requirements

Version: API 16 or later
Header: APIdefs_Attributes.h

 

See Also

API_Attr_Head, API_Attribute, API_DailyProfile , API_DailyProfileUsage, API_HourlyProfile
Attribute Manager, API Types