API_​OverriddenAttribute

Attribute override structure.

    typedef struct {
        API_AttributeIndex attributeIndex;
        bool               overridden;
        bool               filler_1[3];
    } API_OverriddenAttribute;

Members

attributeIndex
Contains the overridden attribute index.
overridden
If true, the attribute is overridden on the relevant level.

 

Remarks

Attributes (e.g. surface materials in the building materials) can be overridden on the element level.
This structure is used inside elements’ API structures, wherever attribute overrides are available.

 

Requirements

Version: API 20 or later
Header: APIdefs_Elements.h

 

See Also

API_AttributeIndex
API_OverriddenAttributeOrRGB