API_​OverriddenAttributeOrRGB

Attribute override structure with option, to override with explicit RGB color.

	struct API_OverriddenAttributeOrRGB {
        GS::Variant<API_AttributeIndex, API_RGBColor>   attributeStyle;
        bool				                overridden;
        bool				                filler_1[3];
    };

Members

attributeStyle
Contains the overridden attribute style, that is an attribute index, or an RGB color value.
overridden
If true, the attribute is overridden on the relevant level.

 

Requirements

Version: API 25 or later
Header: APIdefs_Elements.h

 

See Also

API_AttributeIndex
API_OverriddenAttribute