API_​OverrideRule

Represents an override rule.

    typedef struct {
        API_Guid                  guid;
        GS::UniString             name;
        API_OverrideRuleStyle     style;
        GS::UniString             criterionXML;
    } API_OverrideRule;

 

Members

guid
A unique identifier for the override rule
name
The name of the rule, that is unique within its project
style
Specifies what, and how this rule should override
criterionXML
Specifies when this rule should be used. To get the proper criterion XML, save the configured override rule as XML in Archicad. See the Override_Test add-on about the format of the XML

 

Requirements

Version: API 20 or later
Header: APIdefs_Environment.h

 

See Also

Visual Override,
API Types