API_​OverrideRuleStyle

Specifies what, and how an API_OverrideRule should override.

    struct API_OverrideRuleStyle {
        API_OverriddenAttribute       lineType;
        API_OverriddenAttribute       lineMarkerTextPen;
        API_OverriddenAttribute       fillOverride;
        API_OverriddenFillType        fillType;
        API_OverriddenAttribute       fillForegroundPenOverride;
        API_OverriddenFillType        fillTypeForegroundPen;
        API_OverriddenAttributeOrRGB  fillBackgroundPenOverride;
        API_OverriddenFillType        fillTypeBackgroundPen;
        API_OverriddenAttributeOrRGB  surfaceOverride;
        API_OverriddenSurfaceType     surfaceType;
        bool                          showSkinSeparators;
        bool                          overridePenColorAndThickness;
        API_OverriddenSurfaceType     hiddenContours;
        bool                          overrideContours;
    };
    

 

Members

lineType
Specifies how the line type should be overridden
lineMarkerTextPen
Specifies how the line/marker/text pen should be overridden
fillOverride
Specifies how the fills should be overridden
fillType
Specifies which fills should be overridden
fillForegroundPenOverride
Specifies how the fill foreground pen should be overridden
fillTypeForegroundPen
Specifies which fill foreground pen should be overridden
fillBackgroundPenOverride
Specifies how the fill background pen should be overridden
fillTypeBackgroundPen
Specifies which fill background pen should be overridden
surfaceOverride
Specifies how the surface should be overridden
surfaceType
Specifies which surface should be overridden
showSkinSeparators
Specifies if the skin separators should be shown
overridePenColorAndThickness
Specifies if the pen color and thickness should be overridden
hiddenContours
Specifies which contours should be hidden
overrideContours
Specifies if contour hiding should be overridden

 

Remarks

New in API 25 In version 25, the fillBackgroundPenOverride and surfaceOverride members type are changed to API_OverriddenAttributeOrRGB

New in API 25 In version 25, hiddenContours and overrideContours are added

 

Requirements

Version: API 20 or later
Header: APIdefs_Environment.h

 

See Also

Visual Override,
API Types