Specifies what is overridden and how, for an API_Element.
typedef struct { API_OverriddenAttribute lineType; API_OverriddenAttribute lineMarkerTextPen; bool overrideLinePenThickness; API_OverriddenAttribute cutFillType; API_OverriddenAttribute cutFillFGPen; API_OverriddenAttributeOrRGB cutFillBGPen; bool overrideCutFillFGThickness; API_OverriddenAttribute coverFillType; API_OverriddenAttribute coverFillFGPen; API_OverriddenAttributeOrRGB coverFillBGPen; bool overrideCoverFillFGThickness; API_OverriddenAttribute draftFillType; API_OverriddenAttribute draftFillFGPen; API_OverriddenAttributeOrRGB draftFillBGPen; bool overrideDraftFillFGThickness; API_OverriddenAttributeOrRGB cutSurfaceType; API_OverriddenAttributeOrRGB uncutSurfaceType; bool showSkinSeparators; bool hideCutContours; bool hideUncutContours; } API_OverrideStyle;
Members
- lineType
- Specifies how the line type should be overridden
- lineMarkerTextPen
- Specifies how the line/marker/text pen should be overridden
- overrideLinePenThickness
- Specifies if line and pen thickness should be overridden
- cutFillType
- Specifies how the cut fills should be overridden
- cutFillFGPen
- Specifies how the cut fill foregrounds should be overridden
- cutFillBGPen
- Specifies how the cut fill backgrounds should be overridden
- overrideCutFillFGThickness
- Specifies whether the cut fill foreground pen thickness should be overridden
- coverFillType
- Specifies how the cover fills should be overridden
- coverFillFGPen
- Specifies how the cover fill foregrounds should be overridden
- coverFillBGPen
- Specifies how the cover fill backgrounds should be overridden
- overrideCoverFillFGThickness
- Specifies whether the cover fill foreground pen thickness should be overridden
- draftFillType
- Specifies how the draft fills should be overridden
- draftFillFGPen
- Specifies how the draft fill foregrounds should be overridden
- draftFillBGPen
- Specifies how the draft fill backgrounds should be overridden
- overrideDraftFillFGThickness
- Specifies whether the draft fill foreground pen thickness should be overridden
- cutSurfaceType
- Specifies how the cut surfaces should be overridden
- uncutSurfaceType
- Specifies how the uncut surfaces should be overridden
- showSkinSeparators
- Specifies if the skin separators should be shown
- hideCutContours
- Specifies if the contours of the cut surface should be hidden
- hideUncutContours
- Specifies if the contours of the uncut surface should be hidden
Remarks
In version 25, the cutFillBGPen, coverFillBGPen, draftingFillBGPen, cutSurfaceType and uncutSurfaceType members type are changed to API_OverriddenAttributeOrRGB
In version 25, the hideCutContours and hideUncutContours are added
Requirements
- Version: API 20 or later
- Header: APIdefs_Environment.h