API_​ParamOwnerType

Parameters to specify the target parameter list to change.

    typedef struct {
        API_Guid                guid;
        Int32                   libInd;
        API_ElemType            type;
        Int32                   filler_1;
    } API_ParamOwnerType;

 

Members

guid API version 18
element unique ID
libInd
library part index
type
element type

 

Remarks

This structure is used to specify the target of which the parameter list should be opened to edit. Possible targets are:

  • parameters of a placed element (Library Part instance)
  • default parameters of an element (default tool settings)
  • default parameters of a Library Part itself

The required parametrization to each case:

Library part default

API_ParamOwnerType

guid

ignored

libInd

required; set to the Library Part index

type

ignored

Element default

API_ParamOwnerType

guid

required; set to APINULLGuid

libInd

required; set to zero

type

required

 

Placed element

API_ParamOwnerType

guid

required; set to the element unique ID

libInd

required; set to zero

type

required

For the utilization of API_ParamOwnerType see the APIAny_OpenParametersID function.

Changed in API 26  From version 26 the typeID and variationID members were merged into an API_ElemType structure.

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Goodies.h

 

See Also

APIAny_OpenParametersID, API_ElemType, API Types