API_​PenOverrideType

Pen override structure.

    typedef struct {
        short     cutFillPen;
        short     cutFillBackgroundPen;
        bool      overrideCutFillPen;
        bool      overrideCutFillBackgroundPen;
        bool      filler_1[2];
    } API_PenOverrideType;

Members

cutFillPen
Contains the cut fill foreground pen index.
cutFillBackgroundPen
Contains the cut fill background pen index.
overrideCutFillPen
If true, the cut fill foreground pen is overridden on the element.
overrideCutFillBackgroundPen
If true, the cut fill background pen is overridden on the element.

 

Remarks

Cut fill pens defined in the structural atributes (building material, composite, complex profile) can be overridden on the element level.
This structure is used inside elements’ API structures, where pen overriding is available.

 

Requirements

Version: API 17 or later
Header: APIdefs_Elements.h