Specifies which pen table a drawing element uses.
typedef enum { APIPenTableUsageMode_UseOwnPenTable, APIPenTableUsageMode_UseModelPenTable, APIPenTableUsageMode_UsePenTableIndex } API_PenTableUsageModeValues;
Members
- APIPenTableUsageMode_UseOwnPenTable
- Use the drawing element’s own pen table; i.e. the colors stored in the drawing data itself.
- APIPenTableUsageMode_UseModelPenTable
- Use the pen table of the model space; this value is valid only for the drawing element default.
- APIPenTableUsageMode_UsePenTableIndex
- Use the pen table defined by the
penTableIndex
field in API_DrawingType
Requirements
- Version: API 10 or later
- Header: APIdefs_Elements.h