Pen attribute representation.
typedef struct { API_Attr_Head head; API_RGBColor rgb; double width; char description[128]; } API_PenType;
Members
- head
- Specifies the index of the pen.
- rgb
- Color of the pen.
- width
- Thickness of the pen defined in millimeters.
- description
- Textual description of the pen; doesn’t have to be unique, and can be empty.
Remarks
This structure is used to manipulate pen attributes of the currently active Pen Table. Pens cannot be created or deleted; you can just modify them.
There is no additional data assigned to pen attributes in the API_AttributeDef structure.
The index of Pen attributes normally must be between 1 and 255, but there are some special values:
Index | Meaning |
---|---|
APIPen_Transparent (= 0) | Transparent pen Fill backgrounds having this pen index are drawn transparently. |
APIPen_WindowBackground (= -1) | Background pen ![]() Fill backgrounds having this pen index are drawn with the current window background color. |
1000 | Grid color pen Pen index for drawing the grid |
1001 | Zone fill color ![]() This is the foreground color of a zone’s fill; coming from the zone category; use the rgb value of the pen |
1002 | Ghost Story color Pen index used for drawing ghost story elements |
Requirements
- Version: API 1.3 or later
- Header: APIdefs_Attributes.h
See Also
API_RGBColor, API_Attr_Head
API_Attribute, API_PenTableType
Attribute Manager, API Types