API_​PersCamSetPars

Represents a perspective camera set.

    typedef struct {
        bool      openedPath;
        bool      bezierPath;
        bool      smoothTarget;
        bool      filler_1;
        short     filler_2;
        short     pen;
        Int32     inFrames;
        Int32     showFrom;
        Int32     showTo;
        Int32     filler_3;
    } API_PersCamSetPars;

 

Members

openedPath
Open or closed animation path?
bezierPath
Generate the in-between frames along polygonal or Bezier animation path?
smoothTarget
Generate the in-between frames along a straight line or a smooth curve?
pen
Pen attribute index of the camera and the path.
inFrames
Number of the in-between frames.
showFrom
First camera index in slide.
showTo
Last camera index in slide.

 

Remarks

These fields correspond to the fields of the Path Options dialog.

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Elements.h

 

See Also

API_CamSetType, API Types