Parameters of a perspective camera.
typedef struct { API_PerspPars persp; short waitFrames; short pen; Int32 filler_1; API_Guid prevCam; API_Guid nextCam; double lenPrev; double lenNext; double dirAng; bool active; bool filler_2[7]; Int32 filler_3[6]; } API_PerspCamPars;
Members
- persp
- Perspective projection settings of the camera.
- waitFrames
- Number of the frames to wait here.
- pen
- Pen attribute index for the camera.
- prevCam
- Guid of the previous camera in the same camera set (APINULLGuid if no previous camera).
- nextCam
- Guid of the following camera in the same camera set (APINULLGuid if no following camera).
- lenPrev
- Bezier direction length previous.
- lenNext
- Bezier direction length next.
- dirAng
- Bezier direction angle (radian).
- active
- Active in the path?
Requirements
- Version: API 2.1 or later
- Header: APIdefs_Elements.h