API_​PerspPars

Perspective projection parameters.

    typedef struct {
        double                   azimuth;
        API_SunAngleSettings     sunAngSets;
        double                   viewCone;
        double                   rollAngle;
        double                   distance;
        double                   cameraZ;
        double                   targetZ;
        bool                     isTwoPointPersp;
        bool                     filler_0[7];
        double                   filler_1[7];
        API_Coord                pos;
        API_Coord                target;
        double                   filler_2[8];
    } API_PerspPars;

 

Members

azimuth
rotation angle of the camera around the target
sunAngSets  API 21 feature
Sun’s angle settings
viewCone
angle of the camera view cone
rollAngle
roll angle of the camera
distance
distance of the camera and the target
cameraZ
Z coordinate of camera position
targetZ
Z coordinate of target position
isTwoPointPersp  API 20 feature
Two-point perspective mode
pos
X and Y coordinate of camera position
target
X and Y coordinate of target position

 

Remarks

This structure corresponds to parameters set in the “3D Projection Settings…” dialog of Archicad, when a perspective view is selected.

Refer to the APIEnv_Get3DProjectionSetsID function to get the actual projection parameters.

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Elements.h

 

See Also

APIEnv_Get3DProjectionSetsID, API_Coord, API_SunAngleSettings, API Types