API_​PetPaletteType

Parameters for performing user input with pet palette.

    typedef struct {
        short           petPaletteID;
        short           nCols;
        short           nRows;
        short           value;
        UInt32          grayBits;
        short           **petIconIDsHdl;
        short           dhlpResourceID;
        short           obsolete;
        GSResModule     petIconResModule;
        Int32           filler_1[5];
    } API_PetPaletteType;

 

Members

petPaletteID
Unique identifier of the pet palette.
nCols
Number of columns in the picture.
nRows
Number of columns in the picture.
value
The actual value of the control (starts from 1).
grayBits
The disabled items of the control.
petIconIDsHdl
Handle of the array of the ‘GICN’ resource IDs of the pet items; each item should be 22×22 pixels.
dhlpResourceID 10
‘DHLP’ resource ID (the tooltip and help anchor pairs).
obsolete 10
Previously used to be toolTipStrListID, now obsolete, not used.
petIconResModule API 18
Resource module to load the icon resource from.

 

Remarks

This structure holds the input parameters for the APIIo_PetPaletteID interface function.

10  The help handling is changed because of the new help system. There are help anchor strings instead of the context help texts now, and tooltip strings. You should use the ‘DHLP’ resource, you can store the tooltip string and context help anchor pairs in one resource.

For more details refer to APIIo_PetPaletteID.

 

Requirements

Version: API 5.1 or later
Header: APIdefs_Interface.h

 

See Also

APIIo_PetPaletteID
API Types