Parameters for saving photorendered picture into image file.
typedef struct { API_FTypeID fileTypeID; Int32 filler_1; IO::Location *file; API_ColorDepthID colorDepth; bool dithered; bool filler_2[7]; Int32 filler_3[30]; } API_PhotoRenderPars;
Members
- fileTypeID
- Image file format for saving the picture. Valid values are:
APIFType_PictFile
,APIFType_BMPFile
,APIFType_TIFFFile
,APIFType_JPEGFile
andAPIFType_GIFFile
- filler_1
- Reserved for further use
- file
- File specification for saving the picture
- colorDepth
- Color depth of the picture to be saved
- dithered
- Use dithering when saving the picture
Remarks
This structure is used by the APIDo_PhotoRenderID automation function.
Requirements
- Version: API 3.1 or later
- Header: APIdefs_Automate.h