Storage format of a picture.
typedef enum { APIPictForm_Default, APIPictForm_Bitmap, APIPictForm_GIF, APIPictForm_TIFF, APIPictForm_JPEG, APIPictForm_PNG } API_PictureFormat;
Members
- APIPictForm_Default
- Default format
- APIPictForm_Bitmap
- Bitmap file storage format
- APIPictForm_GIF
- GIF file storage format
- APIPictForm_TIFF
- TIFF file storage format
- APIPictForm_JPEG
- JPEG file storage format
- APIPictForm_PNG
- PNG file storage format
Remarks
This enum is used when you convert a picture from a given format to another with the APIAny_ConvertPictureID goody function.
API_PictureFormat is also a part of the API_PictureType structure.
You might also use MIME types for identifying the standard image formats instead of API_PictureFormat. See the APIAny_ConvertMimePictureID goody function.
Requirements
- Version: API 2.1 or later
- Header: APIdefs_Elements.h
See Also
API_PictureType
APIAny_ConvertPictureID
APIAny_ConvertMimePictureID
API Types