Represents a figure (picture) element.
typedef struct { API_Elem_Head head; bool mirrored; bool usePixelSize; short pixelSizeX; short pixelSizeY; bool transparent; bool directCreate; double rotAngle; API_Box destBox; API_Box origBox; API_ColorDepthID colorDepth; API_AnchorID anchorPoint; API_PictureFormat storageFormat; Int32 filler_1; GS::uchar_t pictName[API_UniLongNameLen]; char mime[128]; Int32 filler_2[6]; } API_PictureType;
Members
- head
- General element header.
- mirrored
True
if mirrored to local vertical axis.- usePixelSize
- Has meaning only when creating the picture, see the table below.
- pixelSizeX
- Physical x size in pixels (When creating the picture and
usePixelSize
istrue
, then the logical x size in pixels of the current zoom. See the table below.) - pixelSizeY
- Physical y size in pixels (When creating the picture and
usePixelSize
istrue
, then the logical y size in pixels of the current zoom. See the table below.) - transparent
- White pixels of the picture are drawn transparently.
- directCreate
- Create the picture element without parameter checking and re-calculating (input only).
- rotAngle
- Rotation angle.
- destBox
- Current box of the picture (when creating the picture, see the table below).
- origBox
- Original box of the picture.
- colorDepth
- Color depth of the image, see API_ColorDepthID.
- anchorPoint
- Anchor point of core, see API_AnchorID.
- storageFormat
- Storage format of the picture.
- pictName[API_UniLongNameLen]
- Unicode (UTF-16) name of the picture.
- mime[128]
- MIME string identifying the image format (output only).
Remarks
|
|
|
---|---|---|
mirrored |
|
|
pixelSizeX |
|
|
pixelSizeY |
|
|
rotAngle |
|
|
destBox: xMin, yMin |
|
|
destBox: xMax, yMax |
|
|
origBox |
|
|
colorDepth |
|
|
anchorPoint |
|
|
storageFormat |
|
|
pictName |
|
|
Creating
Not creating
Use the directCreate
option if you do not want the parameters you passed to be checked and re-calculated.
Requirements
- Version: API 2.1 or later
- Header: APIdefs_Elements.h
See Also
API_Elem_Head, API_Box, API_ColorDepthID, API_AnchorID, API_PictureFormat, API_Element,
API_ElementMemo,
Element Manager, API Types