API_​PivotPolyEdgeData

Complete polygon descriptor for polyroofs and shells. This structure is used in API_ElementMemo.

    typedef struct {
        UInt32                         pivotEdgeUnId;
        Int32                          filler1;
        API_RoofSegmentData            *levelEdgeData;
        Int32                          nLevelEdgeData;
        API_ShellBaseSegmentTypeID     segmentType;
        Int32                          segmentsByArc;
        Int32                          segmentsByCircle;
    } API_PivotPolyEdgeData;

 

Members

pivotEdgeUnId
Unique identifier of the pivot polygon edge.
levelEdgeData
Array of API_RoofSegmentData items.
nLevelEdgeData
Number of items in the levelEdgeData array (indexed from 0).
segmentType
Arc decomposition method for polyroof pivot edges or revolved shells. (see API_ShellBaseSegmentTypeID).
segmentsByArc
Cut the arc itself into segmentsByArc straight segments.
segmentsByCircle
Cut a whole circle to segmentsByCircle segments and use as many as necessary to cover the arc.

 

Requirements

See ACAPI_Element_GetMemo to find out which element type needs/provides which information in the memo.

 

Requirements

Version: API 15 or later
Header: APIdefs_Elements.h

 

See Also

API_RoofType, API_PolyRoofData
API_RoofSegmentData, API_ShellBaseSegmentTypeID
ACAPI_Element_GetMemo, API_ElementMemo
Element Manager, API Types