API_​PlaceInfo

The current location, date and sun parameters.

    typedef struct {
        short                  filler_0;
        bool                   sumTime;
        bool                   filler_1;
        unsigned short         year;
        unsigned short         month;
        unsigned short         day;
        unsigned short         hour;
        unsigned short         minute;
        unsigned short         second;
        double                 longitude;
        double                 latitude;
        double                 altitude;
        double                 north;
        double                 sunAngXY;
        double                 sunAngZ;
        API_NorthUnitID        northUnit;
        API_AltitudeUnitID     altitudeUnit;
        API_LongLatUnitID      longLatUnit;
        short                  timeZoneInMinutes;
        short                  timeZoneOffset;
        Int32                  filler_3[2];
    } API_PlaceInfo;

 

Members

sumTime
true if daylight saving time is in effect
year Changed in API 22
The year at the given place.
month Changed in API 22
The month at the given place.
day Changed in API 22
The day at the given place.
hour Changed in API 22
The hour at the given place.
minute Changed in API 22
The minute at the given place.
second Changed in API 22
The second at the given place.
longitude New in API 16
longitude in degrees
latitude New in API 16
latitude in degrees
altitude New in API 16
altitude in meters
north
North direction in radians.
sunAngXY
Sun position component in radians.
sunAngZ
Sun position component in radians.
northUnit Featuring API 15
angle unit of north direction. See also: API_NorthUnitID
altitudeUnit New in API 16
display altitude in meters or feet. See also: API_AltitudeUnitID
longLatUnit New in API 16
display latLongUnit in decimal degrees or degrees, minutes and seconds. See also: API_LongLatUnitID
timeZoneInMinutes Changed in API 22
Time zone in minutes from Greenwich.
timeZoneOffset Changed in API 22
Used when different timezones have the same timeZoneInMinutes.

 

Remarks

This structure is used to hold the consistent location, date and sun parameters.

It can be used either to retrieve the current parameter set (see the APIEnv_GetPlaceSetsID function); or to calculate the sun angles in a given place at a given time (see the APIAny_CalcSunOnPlaceID function); or to set/change and the current parameter set (see APIEnv_ChangePlaceSetsID function).

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Environment.h

 

See Also

APIAny_CalcSunOnPlaceID, APIEnv_GetPlaceSetsID, APIEnv_ChangePlaceSetsID, API Types, API_LongLatUnitID, API_NorthUnitID, API_AltitudeUnitID