This structure holds the Single-plane Roof specific data of API_RoofType.
typedef struct { double angle; API_Polygon poly; API_Sector baseLine; bool posSign; bool filler_1[7]; } API_PlaneRoofData;
Members
- angle
- Angle of the roof plane.
- poly
- The polygon of the roof slab, projected onto the horizontal plane.
- baseLine
- Base (pivot) line of the roof.
- posSign
- The sign of the vectorial product of the pivot line vector and the elevation indicator point (its value is 1 if the roof plane raises on the left side of the pivot line vector, otherwise 0).
Remarks
For roof related memo data see the ACAPI_Element_GetMemo function.
Requirements
- Version: API 15 or later
- Header: APIdefs_Elements.h
See Also
API_Polygon, API_Sector
API_RoofType, API_PolyRoofData
API_Element, API Types