API_​PolyArc

Representation of an arc segment of a two dimensional polygon.

    typedef struct {
        Int32      begIndex;
        Int32      endIndex;
        double     arcAngle;
    } API_PolyArc;

 

Members

begIndex
Node index of one end point of the arc
endIndex
Node index of the other end point of the arc
arcAngle
Angle of the arc; it is positive, if the arc is on the right-hand side of the straight segment.

 

Remarks

Refer to the API_Polygon structure for more details.

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Base.h

 

See Also

API_Polygon, API Types