This structure holds the Multi-plane Roof specific data of API_RoofType.
typedef struct { API_RoofLevelData levelData[16]; short levelNum; short filler_1; API_RoofOverHangTypeID overHangType; double eavesOverHang; API_ShellBaseSegmentTypeID segmentType; Int32 segmentsByArc; Int32 segmentsByCircle; bool fitSkylightToCurve; bool filler_2[3]; API_Polygon pivotPolygon; API_Polygon contourPolygon; } API_PolyRoofData;
Members
- levelData
- Fixed-size array of API_RoofLevelData items.
- levelNum
- The actual number of levelData items (the maximum value is 16).
- overHangType
- Overhang value is calculated or manually set for each roof segment.
- eavesOverHang
- Eaves’ extension outside the pivot polygon.
- segmentType
- Curve resolution method: by circle or by arc.
- segmentsByArc
- Curve resolution value by arc.
- segmentsByCircle
- Curve resolution value by circle.
- fitSkylightToCurve
- Place Skylights tangentially to curved surfaces rather than parallel to the individual segments.
- pivotPolygon
- The polygon constructed from the pivot edges of the roof planes. The actual data of the pivot polygon is held in the
pivotPolyCoords
,pivotPolyPends
,pivotPolyParcs
, andpivotPolyVertexIDs
members of the API_ElementMemo structure. - contourPolygon
- The contour polygon that cuts the roof on the horizontal plane. The actual data is held in the
coords
,pends
,parcs
, andvertexIDs
members of the API_ElementMemo structure.
Remarks
For roof related memo data see the ACAPI_Element_GetMemo function.
In order to enumerate the planes of the Multi-plane Roof, use the ACAPI_Element_Decompose function.
Requirements
- Version: API 15 or later
- Header: APIdefs_Elements.h
See Also
API_Elem_Head, API_ShellBaseType, API_RoofLevelData
API_RoofOverHangTypeID, API_ShellBaseSegmentTypeID
API_RoofType, API_PlaneRoofData
API_Element, API_ElementMemo
ACAPI_Element_GetMemo
ACAPI_Element_Decompose
Element Manager, API Types