API_​PolyRoofSegmentAngleTypeID

Type of the segment of Multi-plane Roofs.

    typedef enum {
        APIPolyRoof_SegmentAngleTypeSloped,
        APIPolyRoof_SegmentAngleTypeGable
    } API_PolyRoofSegmentAngleTypeID;

 

Members

APIPolyRoof_SegmentAngleTypeSloped
Defines a normal segment of Multi-plane Roofs.
APIPolyRoof_SegmentAngleTypeGable
Defines a Gable.

 

Requirements

Version: API 15 or later
Header: APIdefs_Elements.h

 

See Also

API_RoofType, API_PolyRoofData
Element Manager
API Types