Header information for primitive elements.
typedef struct { API_PrimTypeID typeID; API_AttributeIndex layer; API_ExtendedPenType pen; short drwIndex; short filler_1[3]; API_RenovationStatusType renovationStatus; } API_Prim_Head;
Members
- typeID
- Type of the primitive element (see API_PrimTypeID).
- layer
- Layer attribute index of the parent element.
- pen
- (Overridden) pen attribute index of the primitive element.
- drwIndex
- Drawing order index of the original element if the primitive element is a part of the content of a drawing element generated from a view.
- renovationStatus
- Renovation Status of the original element.
Requirements
- Version: API 2.1 or later
- Header: APIdefs_Elements.h
See Also
API_AttributeIndex
API_PrimTypeID
API_PrimElement
API_PrimHotspot
API_ExtendedPenType
API Types